IVW
Hallo, Gast! Registrieren
Hol dir unsere App: iszene.com App

Kein Simulator mehr in Xcode
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
noX1609 Offline
***Nachteule***
*****
Avatar
Beiträge: 7.886
Registriert seit: Jan 2008
Bewertung: 180

30.07.2015, 14:43 | #1
Kein Simulator mehr in Xcode
Hi Leute,

als erstes, hoffe ich dass ich hier richtig bin, aber hab nur den Bereich gefunden für Dev's. Sollte es doch falsch sein, dann entschuldigung und es wäre klasse wenn ihr es verschieben könntet.

Ich habe ein Problem.

Bis zur DP3 von 10.11 hatte ich in Xcode 7 Beta auch die Simulatoren.
Habe dann auf ner zweiten Partition 10.10 installiert um meine Apps auch in den Store zu bringen.
Seit dem ich die zweite Installation habe und 10.11 auf DP4 gebracht habe, habe ich keine Simulatoren mehr in den Xcode 7 Beta's, egal in welcher, hab es mit allen 4 Xcode Betas versucht.
Weiß jetzt halt nicht, ob es an der zweiten Install liegt oder an der Beta von 10.11, da ich nach der Install von 10.10 auf der zweiten Partition nur noch die benutzt habe, nur zum updaten von der OSX Beta habe ich 10.11 gestartet. Erst gestern habe ich meine neue App unter watchOS 2 testen wollen, was nur leider nicht mehr ging, da kein Simulator verfügbar, nur noch das iOS Device. Ich dachte dann es liegt vielleicht an der DP 4 und hab upgedatet, aber ging dann immer noch nicht.
Auch das manuelle hinzufügen von Simulatoren geht nicht mehr.
Unter 10.10, also der zweiten Install, funktioniert Xcode 6.4 ohne Probleme.

Hatte dass einer von euch schon mal dass die Simulatoren weg waren und weiß wie ich die wieder bekomme?
Denn ohne die ist das Entwickeln für iOS 9 und watchOS 2 unmöglich, will es nicht immer auf mein Device installieren, wenn ich was testen will.
Zitat @
mario4848 Offline
Posting Freak
*****
Avatar
Beiträge: 1.253
Registriert seit: Dec 2008
Bewertung: 17

30.07.2015, 17:40 | #2
RE: Kein Simulator mehr in Xcode
Erneut runterladen geht nicht?
Zitat @
noX1609 Offline
***Nachteule***
(Threadstarter)
*****
Avatar
Beiträge: 7.886
Registriert seit: Jan 2008
Bewertung: 180

30.07.2015, 19:11 | #3
RE: Kein Simulator mehr in Xcode
@mario4848: Hab ich versucht, leider ohne Erfolg. Hatte extra alle Xcode Versionen gelöscht und die neueste Beta von Xcode 7 geladen aus dem Dev Center, aber leider auch da nur das iOS Device verfügbar.


EDIT: Ok scheint an der Beta von Xcode zu liegen, im Apple Forum berichten noch einige Leute mehr über genau das Problem das ich habe inkl. einer Lösung.
Man muss unter "/Library/Developer/CoreSimulator/Profiles/Runtimes" alles löschen was in dem Ordner ist, dann Xcode beenden und neustarten. Danach waren bei mir die Simulatoren wieder vorhanden Smiley
Scheint aber laut dem Forum nicht bei allen zu gehen, aber bei einigen, also falls hier jemand das Problem hat, kann er das auch versuchen.
(Dieser Beitrag wurde zuletzt bearbeitet: 30.07.2015, 19:28 von noX1609.)
Zitat @



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste